rwhn.net
当前位置:首页 >> Struts2 换了jAr包和xwork2.1.2.jAr 后报错,请大... >>

Struts2 换了jAr包和xwork2.1.2.jAr 后报错,请大...

缺少包了吧

看你要什么需求了,最基本的5个包不能少,分别是commons-logging-api-1.1.jar,freemarker-2.3.16.jar,ognl-3.0.jar,struts2-core-2.2.1.1.jar,xwork-core-2.2.1.1.jar 如果需要上传文件就需要commons-fileupload-1.2.1.jar,若要用到json则...

struts2.1.8所必须的jar包如下: commons-fileupload-2.1.8.jar; commons-io-1.3.2.jar; freemarker-2.3.16.jar; javassist-3.7.ga.jar; ognl-3.0.jar; struts2-core-2.1.8.1.jar; xwork-core-2.1.8.1.jar Struts 2是Struts的下一代产品,...

总结原因有两种:1.jar包导入重复 2.json包版和struts本不一致 3.修改了tomcat里的context.xml文件,在context 元素下添加

我做struts2.3.15 升级到2.3.20的时候记得当时替换了9个jar 只替换其中struts-core肯定是不行的,依赖的common那些也有版本升级,对比一下官方struts下载全量包和你项目里的jar是否有版本变化,有变化的都要升级。 再就是仔细看看日志,看看问题...

不能修改struts2自带的标签库,可以自定义标签,并配置在主配置文件里面。Struts2只需要下面几个包: commons-logging-1.0.4.jar 日志管理 freemarker-2.3.8.jar 表现层框架,定义了struts2的可视组件主题(theme) ognl-2.6.11.jar OGNL表达式...

struts2.1.6 支持jar包 xwork-2.1.2.jar struts2-core-2.1.6.jar commons-logging-1.0.4.jar freemarker-2.3.13.jar ognl-2.6.11.jar commons-fileupload-1.2.1.jar spring2.5.6支持jar包 spring.jar cglib-nodep-2.1_3.jar dom4j-1.6.1.jar log...

我也是加入struts2-convention-plugin-2.2.1.jar包后tomcat启动报错,当我把asm-3.3这个包也加入后就不报错了,不知道你的是不是这个问题。

1检查版本 2检查配置 ~

我前几天刚做的2.3.1.2升级到2.3.15.1GA 如果你的应用没有修改过struts2的源码,那升级很简单 增加3个jar struts2一个,xwork一个,把原版本的替换掉,另外增加一个common-lang3的包 其他什么都不用动。 web.xml struts.xml没有变化,只是15版本...

网站首页 | 网站地图
All rights reserved Powered by www.rwhn.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com